We are pleased to advise that the issue affecting the UCme app on iPhone has now been resolved.
A new release of the UCme application (version available on the App Store) was released on Saturday morning at approximately 2:00 AM AEST, addressing the crash on launch that a number of users experienced.
If you are still experiencing issues, please ensure you have updated to the latest version of the UCme app via the App Store.
We apologise for any inconvenience caused and thank you for your patience while we worked to resolve this matter.
Posted Apr 27, 2026 - 11:12 AEST
Investigating
We are currently investigating an issue affecting the UCme app on iPhone, where the app is crashing immediately upon launch.
We believe the issue began overnight and, as no changes have been made to the UCme app, we have escalated directly with Apple to determine whether a recent iOS update may be the cause.
Our team is actively monitoring the situation and will provide further updates as soon as more information is available. We apologise for any inconvenience this may cause.
Posted Apr 24, 2026 - 08:50 AEST
This incident affected: Voice Services (Hosted PBX).