Voice - Service Disruption 07/07/2026 7:30 AM AEST CH:673401

Incident Report for Telair

Resolved

The issue affecting PBX services has been resolved.

If you are still experiencing issues, please reboot your handset — if this does not resolve your issue, please contact Telair Technical Support by submitting a new ticket at https://support.telair.com.au or call our team on 1300 557 931.
Posted Jul 07, 2026 - 08:26 AEST

Investigating

We are aware of an issue affecting some Hosted PBX services. Our senior Voice Engineer is investigating and working to resolve this as a priority. We will provide updates as more information becomes available.
Posted Jul 07, 2026 - 08:13 AEST
This incident affected: Voice Services (Hosted PBX).