Our engineers identified the issue impacting a subset of PBX systems. Users on these systems were unable to register extensions. This has been resolved.
Posted Apr 16, 2026 - 09:58 AEST
Monitoring
A fix has been implemented, and inbound calling has been restored from 9:00 AM AEST. Service restoration is continuing as expected, with affected services progressively coming back online and steady improvement being observed across the platform.
If you are still experiencing issues, please reboot your extension handset or reauthenticate on your UCme app to restore service.
We are continuing to closely monitor the platform and, provided stability is maintained, plan to close this incident within the next hour.
We will provide a final update once all services have been fully restored and confirmed stable.
Posted Apr 16, 2026 - 09:58 AEST
Update
We are continuing to investigate this issue.
Posted Apr 16, 2026 - 08:41 AEST
Investigating
Telair is currently aware of an issue impacting the myCloudPBX platform.
Customers may experience difficulties registering extensions and receiving calls.
Our engineers are actively investigating the issue and prioritising service restoration. We will provide a further update as soon as more information becomes available.
Posted Apr 16, 2026 - 08:40 AEST
This incident affected: Voice Services (Hosted PBX).